<!DOCTYPE html>
<html lang="en-CA" prefix="og: http://ogp.me/ns#">
<head>
	<meta charset="UTF-8">
	<meta http-equiv="X-UA-Compatible" content="IE=edge">
	<meta name="viewport" content="width=device-width, initial-scale=1">
	<link rel="profile" href="http://gmpg.org/xfn/11" />
			<link rel="shortcut icon" href="https://mbherald.com/wp-content/uploads/2016/06/Herald-favicon-new-2.gif" type="image/x-icon" />
		<link rel="apple-touch-icon" sizes="180x180" href="https://mbherald.com/wp-content/uploads/2016/06/Herald-favicon-new-2.gif">
		<link rel="alternate" type="application/rss+xml" title="Mennonite Brethren Herald RSS Feed" href="https://mbherald.com/feed/" />
	<link rel="alternate" type="application/atom+xml" title="Mennonite Brethren Herald Atom Feed" href="https://mbherald.com/feed/atom/" />
	<link rel="pingback" href="https://mbherald.com/xmlrpc.php" />
	<!--[if lt IE 9]>
	<script src="https://mbherald.com/wp-content/themes/soledad/js/html5.js"></script>
	<![endif]-->
	<title>Are you exercising spiritual faith? - Mennonite Brethren Herald</title>

<!-- This site is optimized with the Yoast SEO plugin v9.1 - https://yoast.com/wordpress/plugins/seo/ -->
<link rel="canonical" href="https://mbherald.com/faith-mountains/" />
<meta property="og:locale" content="en_US" />
<meta property="og:type" content="article" />
<meta property="og:title" content="Are you exercising spiritual faith? - Mennonite Brethren Herald" />
<meta property="og:description" content="The Faith that Moves Mountains is about activating and operationalizing our faith in God. Author Arisnel Mesidor’s intent is to help the reader understand faith and to wield it boldly according to Jesus’ teaching and modelling." />
<meta property="og:url" content="https://mbherald.com/faith-mountains/" />
<meta property="og:site_name" content="Mennonite Brethren Herald" />
<meta property="article:publisher" content="https://www.facebook.com/MBHerald" />
<meta property="article:tag" content="Arisnel Mesidor" />
<meta property="article:tag" content="discipleship" />
<meta property="article:tag" content="faith" />
<meta property="article:tag" content="global church" />
<meta property="article:tag" content="Lloyd Letkeman" />
<meta property="article:section" content="Arts &amp; Culture" />
<meta property="article:published_time" content="2018-11-19T11:00:04+00:00" />
<meta property="article:modified_time" content="2018-11-19T06:01:57+00:00" />
<meta property="og:updated_time" content="2018-11-19T06:01:57+00:00" />
<meta property="og:image" content="https://i0.wp.com/mbherald.com/wp-content/uploads/2018/11/Lloyd-Arisnel-113777-1-e1542606120934.jpg?fit=1580%2C1150&#038;ssl=1" />
<meta property="og:image:secure_url" content="https://i0.wp.com/mbherald.com/wp-content/uploads/2018/11/Lloyd-Arisnel-113777-1-e1542606120934.jpg?fit=1580%2C1150&#038;ssl=1" />
<meta property="og:image:width" content="1580" />
<meta property="og:image:height" content="1150" />
<script type='application/ld+json'>{"@context":"https:\/\/schema.org","@type":"Organization","url":"https:\/\/mbherald.com\/","sameAs":["https:\/\/www.facebook.com\/MBHerald","https:\/\/twitter.com\/MB_Herald"],"@id":"https:\/\/mbherald.com\/#organization","name":"MB Herald","logo":"https:\/\/mbherald.com\/wp-content\/uploads\/2016\/06\/cropped-Herald-favicon-new-2.gif"}</script>
<!-- / Yoast SEO plugin. -->

<link rel='dns-prefetch' href='//s0.wp.com' />
<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel="alternate" type="application/rss+xml" title="Mennonite Brethren Herald &raquo; Feed" href="https://mbherald.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Mennonite Brethren Herald &raquo; Comments Feed" href="https://mbherald.com/comments/feed/" />
<link rel="alternate" type="text/calendar" title="Mennonite Brethren Herald &raquo; iCal Feed" href="https://mbherald.com/calendar/?ical=1" />
<link rel="alternate" type="application/rss+xml" title="Mennonite Brethren Herald &raquo; Are you exercising spiritual faith? Comments Feed" href="https://mbherald.com/faith-mountains/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/11\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/mbherald.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.9.8"}};
			!function(a,b,c){function d(a,b){var c=String.fromCharCode;l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,a),0,0);var d=k.toDataURL();l.clearRect(0,0,k.width,k.height),l.fillText(c.apply(this,b),0,0);var e=k.toDataURL();return d===e}function e(a){var b;if(!l||!l.fillText)return!1;switch(l.textBaseline="top",l.font="600 32px Arial",a){case"flag":return!(b=d([55356,56826,55356,56819],[55356,56826,8203,55356,56819]))&&(b=d([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]),!b);case"emoji":return b=d([55358,56760,9792,65039],[55358,56760,8203,9792,65039]),!b}return!1}function f(a){var c=b.createElement("script");c.src=a,c.defer=c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var g,h,i,j,k=b.createElement("canvas"),l=k.getContext&&k.getContext("2d");for(j=Array("flag","emoji"),c.supports={everything:!0,everythingExceptFlag:!0},i=0;i<j.length;i++)c.supports[j[i]]=e(j[i]),c.supports.everything=c.supports.everything&&c.supports[j[i]],"flag"!==j[i]&&(c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&c.supports[j[i]]);c.supports.everythingExceptFlag=c.supports.everythingExceptFlag&&!c.supports.flag,c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.everything||(h=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",h,!1),a.addEventListener("load",h,!1)):(a.attachEvent("onload",h),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),g=c.source||{},g.concatemoji?f(g.concatemoji):g.wpemoji&&g.twemoji&&(f(g.twemoji),f(g.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='rs-plugin-settings-css'  href='https://mbherald.com/wp-content/plugins/revslider/public/assets/css/settings.css?ver=5.4.5.1' type='text/css' media='all' />
<style id='rs-plugin-settings-inline-css' type='text/css'>
#rs-demo-id {}
</style>
<link rel='stylesheet' id='penci-fonts-css'  href='//fonts.googleapis.com/css?family=PT+Serif%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPlayfair+Display+SC%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CMontserrat%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CPT+Sans%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%7CCrimson+Text%3A300%2C300italic%2C400%2C400italic%2C500%2C500italic%2C700%2C700italic%2C800%2C800italic%26subset%3Dcyrillic%2Ccyrillic-ext%2Cgreek%2Cgreek-ext%2Clatin-ext&#038;ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='penci_style-css'  href='https://mbherald.com/wp-content/themes/soledad/style.css?ver=4.0.2' type='text/css' media='all' />
<link rel='stylesheet' id='tablepress-default-css'  href='https://mbherald.com/wp-content/plugins/tablepress/css/default.min.css?ver=1.9.1' type='text/css' media='all' />
<link rel='stylesheet' id='mc4wp-form-themes-css'  href='https://mbherald.com/wp-content/plugins/mailchimp-for-wp/assets/css/form-themes.min.css?ver=4.2.5' type='text/css' media='all' />
<link rel='stylesheet' id='social-logos-css'  href='https://mbherald.com/wp-content/plugins/jetpack/_inc/social-logos/social-logos.min.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='jetpack_css-css'  href='https://mbherald.com/wp-content/plugins/jetpack/css/jetpack.css?ver=6.7' type='text/css' media='all' />
<script type='text/javascript' src='https://mbherald.com/wp-includes/js/jquery/jquery.js?ver=1.12.4'></script>
<script type='text/javascript' src='https://mbherald.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.tools.min.js?ver=5.4.5.1'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/plugins/revslider/public/assets/js/jquery.themepunch.revolution.min.js?ver=5.4.5.1'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/plugins/jetpack/_inc/build/postmessage.min.js?ver=6.7'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/plugins/jetpack/_inc/build/jquery.jetpack-resize.min.js?ver=6.7'></script>
<link rel='https://api.w.org/' href='https://mbherald.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://mbherald.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://mbherald.com/wp-includes/wlwmanifest.xml" /> 
<meta name="generator" content="WordPress 4.9.8" />
<link rel='shortlink' href='https://wp.me/p2Kcko-aZP' />
<link rel="alternate" type="application/json+oembed" href="https://mbherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmbherald.com%2Ffaith-mountains%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://mbherald.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fmbherald.com%2Ffaith-mountains%2F&#038;format=xml" />
<style type="text/css">/* =Responsive Map fix
    -------------------------------------------------------------- */
    .ecpt_map_canvas img {
        max-width: none;
    }</style><meta name="tec-api-version" content="v1"><meta name="tec-api-origin" content="https://mbherald.com"><link rel="https://theeventscalendar.com/" href="https://mbherald.com/wp-json/tribe/events/v1/" />
<link rel='dns-prefetch' href='//v0.wordpress.com'/>
<link rel='dns-prefetch' href='//widgets.wp.com'/>
<link rel='dns-prefetch' href='//s0.wp.com'/>
<link rel='dns-prefetch' href='//0.gravatar.com'/>
<link rel='dns-prefetch' href='//1.gravatar.com'/>
<link rel='dns-prefetch' href='//2.gravatar.com'/>
<link rel='dns-prefetch' href='//i0.wp.com'/>
<link rel='dns-prefetch' href='//i1.wp.com'/>
<link rel='dns-prefetch' href='//i2.wp.com'/>
    <style type="text/css">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</style>
    		<style type="text/css">.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}</style>
		<meta name="generator" content="Powered by Visual Composer - drag and drop page builder for WordPress."/>
<!--[if lte IE 9]><link rel="stylesheet" type="text/css" href="https://mbherald.com/wp-content/plugins/js_composer/assets/css/vc_lte_ie9.min.css" media="screen"><![endif]--><meta name="generator" content="Powered by Slider Revolution 5.4.5.1 - responsive, Mobile-Friendly Slider Plugin for WordPress with comfortable drag and drop interface." />
<link rel="icon" href="https://i0.wp.com/mbherald.com/wp-content/uploads/2016/06/cropped-Herald-favicon-new-2.gif?fit=32%2C32&#038;ssl=1" sizes="32x32" />
<link rel="icon" href="https://i0.wp.com/mbherald.com/wp-content/uploads/2016/06/cropped-Herald-favicon-new-2.gif?fit=192%2C192&#038;ssl=1" sizes="192x192" />
<link rel="apple-touch-icon-precomposed" href="https://i0.wp.com/mbherald.com/wp-content/uploads/2016/06/cropped-Herald-favicon-new-2.gif?fit=180%2C180&#038;ssl=1" />
<meta name="msapplication-TileImage" content="https://i0.wp.com/mbherald.com/wp-content/uploads/2016/06/cropped-Herald-favicon-new-2.gif?fit=270%2C270&#038;ssl=1" />
<script type="text/javascript">function setREVStartSize(e){
				try{ var i=jQuery(window).width(),t=9999,r=0,n=0,l=0,f=0,s=0,h=0;					
					if(e.responsiveLevels&&(jQuery.each(e.responsiveLevels,function(e,f){f>i&&(t=r=f,l=e),i>f&&f>r&&(r=f,n=e)}),t>r&&(l=n)),f=e.gridheight[l]||e.gridheight[0]||e.gridheight,s=e.gridwidth[l]||e.gridwidth[0]||e.gridwidth,h=i/s,h=h>1?1:h,f=Math.round(h*f),"fullscreen"==e.sliderLayout){var u=(e.c.width(),jQuery(window).height());if(void 0!=e.fullScreenOffsetContainer){var c=e.fullScreenOffsetContainer.split(",");if (c) jQuery.each(c,function(e,i){u=jQuery(i).length>0?u-jQuery(i).outerHeight(!0):u}),e.fullScreenOffset.split("%").length>1&&void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0?u-=jQuery(window).height()*parseInt(e.fullScreenOffset,0)/100:void 0!=e.fullScreenOffset&&e.fullScreenOffset.length>0&&(u-=parseInt(e.fullScreenOffset,0))}f=u}else void 0!=e.minHeight&&f<e.minHeight&&(f=e.minHeight);e.c.closest(".rev_slider_wrapper").css({height:f})					
				}catch(d){console.log("Failure at Presize of Slider:"+d)}
			};</script>
<noscript><style type="text/css"> .wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head>

<body class="post-template-default single single-post postid-42273 single-format-standard tribe-no-js wpb-js-composer js-comp-ver-5.2.1 vc_responsive">
<a id="close-sidebar-nav" class="header-6"><i class="fa fa-close"></i></a>

<nav id="sidebar-nav" class="header-6">

			<div id="sidebar-nav-logo">
							<a href="https://mbherald.com/"><img class="penci-lazy" src="https://mbherald.com/wp-content/themes/soledad/images/penci-holder.png" data-src="https://mbherald.com/wp-content/uploads/2017/11/newlogo-newsite-grey.png" alt="Mennonite Brethren Herald" /></a>
					</div>
	
	
	<ul id="menu-main-menu" class="menu"><li id="menu-item-37300" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-37300"><a href="###">Categories</a>
<ul class="sub-menu">
	<li id="menu-item-272" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-272"><a href="https://mbherald.com/category/news/">News</a></li>
	<li id="menu-item-271" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-271"><a href="https://mbherald.com/category/faith-life/">Faith &#038; Life ></a>
	<ul class="sub-menu">
		<li id="menu-item-582" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-582"><a href="https://mbherald.com/category/faith-life/articles/">feature articles</a></li>
		<li id="menu-item-583" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-583"><a href="https://mbherald.com/category/faith-life/bible-study/">Bible study</a></li>
		<li id="menu-item-584" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-584"><a href="https://mbherald.com/category/faith-life/inspirational/">inspirational</a></li>
	</ul>
</li>
	<li id="menu-item-274" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-274"><a href="https://mbherald.com/category/views/">Views ></a>
	<ul class="sub-menu">
		<li id="menu-item-586" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-586"><a href="https://mbherald.com/category/views/fr-editor/">From the editor</a></li>
		<li id="menu-item-587" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-587"><a href="https://mbherald.com/category/views/fr-executive/">From CCMBC executive</a></li>
		<li id="menu-item-581" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-581"><a href="https://mbherald.com/category/views/fr-community/">From the community</a></li>
		<li id="menu-item-10675" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10675"><a href="https://mbherald.com/category/views/letters-editor/">Letters to the editor</a></li>
	</ul>
</li>
	<li id="menu-item-270" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-270"><a href="https://mbherald.com/category/arts-culture/">Arts &#038; Culture ></a>
	<ul class="sub-menu">
		<li id="menu-item-278" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-278"><a href="https://mbherald.com/category/arts-culture/art/">art</a></li>
		<li id="menu-item-11721" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11721"><a href="https://mbherald.com/category/arts-culture/books/">books</a></li>
		<li id="menu-item-11722" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11722"><a href="https://mbherald.com/category/arts-culture/music/">Music</a></li>
		<li id="menu-item-280" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-280"><a href="https://mbherald.com/category/arts-culture/film-theatre/">film/theatre</a></li>
	</ul>
</li>
	<li id="menu-item-273" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-273"><a href="https://mbherald.com/category/people/">People ></a>
	<ul class="sub-menu">
		<li id="menu-item-17255" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17255"><a href="https://mbherald.com/category/people/appointments/">Appointments</a></li>
	</ul>
</li>
</ul>
</li>
<li id="menu-item-963" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-963"><a href="https://mbherald.com/calendar/">Calendar</a></li>
<li id="menu-item-2596" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2596"><a href="https://mbherald.com/obituaries/">Obituaries</a>
<ul class="sub-menu">
	<li id="menu-item-37042" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37042"><a href="https://mbherald.com/obituary-submission/">Obituary submission</a></li>
</ul>
</li>
<li id="menu-item-37301" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37301"><a href="https://mbherald.com/subscribe/">Subscribe</a></li>
<li id="menu-item-37302" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37302"><a href="http://www.mennonitebrethren.ca/donate/">Donate</a></li>
<li id="menu-item-10669" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10669"><a href="https://mbherald.com/about/">About</a>
<ul class="sub-menu">
	<li id="menu-item-26608" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26608"><a href="https://mbherald.com/about/website-privacy-policy/">Website Privacy Policy</a></li>
	<li id="menu-item-26635" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26635"><a href="https://mbherald.com/about/website-terms-of-use/">Website terms of use</a></li>
	<li id="menu-item-38858" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38858"><a href="https://mbherald.com/archives/">Archives</a></li>
</ul>
</li>
<li id="menu-item-275" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-275"><a href="https://mbherald.com/contact-us/">Contact Us</a>
<ul class="sub-menu">
	<li id="menu-item-37017" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37017"><a href="https://mbherald.com/subscribe/">Subscribe</a></li>
	<li id="menu-item-17256" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17256"><a href="https://mbherald.com/wp-content/uploads/2018/01/MBH-Family-Life-Announcements.2018.pdf">Family life announcements</a></li>
	<li id="menu-item-37041" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37041"><a href="https://mbherald.com/obituary-submission/">Obituary submission</a></li>
	<li id="menu-item-23779" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23779"><a href="https://mbherald.com/wp-content/uploads/2018/09/Media-Kit-web.pdf">Advertise</a></li>
</ul>
</li>
</ul></nav>

<!-- .wrapper-boxed -->
<div class="wrapper-boxed header-style-header-6">

<!-- Top Bar -->
	<div class="penci-top-bar no-social">
	<div class="container">
		<div class="penci-headline">
										<span class="headline-title">What's New</span>
														<div class="penci-owl-carousel penci-owl-carousel-slider penci-headline-posts" data-auto="true" data-autotime="4500" data-speed="500">
													<div>
								<a class="penci-topbar-post-title" href="https://mbherald.com/faith-mountains/">Are you exercising spiritual faith?</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://mbherald.com/fall-extravaganza-neighbourhood-edition/">Go home and turn on a light</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://mbherald.com/foodgrains-bank-named-one-of-canadas-top-impact-charities-of-2018/">Foodgrains Bank named one of Canada’s top impact...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://mbherald.com/and-action/">And…action!</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://mbherald.com/article-15/">Article 15: Stewardship</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://mbherald.com/transitions-11-2018/">Transitions – November 2018</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://mbherald.com/more-than-8000-postcards-delivered-on-world-food-day/">More than 8,000 postcards delivered on World Food...</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://mbherald.com/how-to-grow/">Hacks for spiritual growth</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://mbherald.com/a-good-meal/">A good meal</a>
							</div>
													<div>
								<a class="penci-topbar-post-title" href="https://mbherald.com/national-ministry-team-sept-18/">Inspire, equip, encourage the church</a>
							</div>
											</div>
									</div>
	</div>
</div>

<header id="header" class="header-header-6 has-bottom-line"><!-- #header -->
	
			<!-- Navigation -->
		<nav id="navigation" class="header-layout-bottom menu-style-1 header-6">
			<div class="container">
				<div class="button-menu-mobile header-6"><i class="fa fa-bars"></i></div>
									<div id="logo">
																					<h2>
									<a href="https://mbherald.com/"><img src="https://mbherald.com/wp-content/uploads/2017/11/newlogo-newsite-grey.png" alt="Mennonite Brethren Herald" /></a>
								</h2>
																		</div>
								<ul id="menu-main-menu-1" class="menu"><li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-37300"><a href="###">Categories</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-272"><a href="https://mbherald.com/category/news/">News</a></li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-271"><a href="https://mbherald.com/category/faith-life/">Faith &#038; Life ></a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-582"><a href="https://mbherald.com/category/faith-life/articles/">feature articles</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-583"><a href="https://mbherald.com/category/faith-life/bible-study/">Bible study</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-584"><a href="https://mbherald.com/category/faith-life/inspirational/">inspirational</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-274"><a href="https://mbherald.com/category/views/">Views ></a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-586"><a href="https://mbherald.com/category/views/fr-editor/">From the editor</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-587"><a href="https://mbherald.com/category/views/fr-executive/">From CCMBC executive</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-581"><a href="https://mbherald.com/category/views/fr-community/">From the community</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-10675"><a href="https://mbherald.com/category/views/letters-editor/">Letters to the editor</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-has-children menu-item-270"><a href="https://mbherald.com/category/arts-culture/">Arts &#038; Culture ></a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-278"><a href="https://mbherald.com/category/arts-culture/art/">art</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11721"><a href="https://mbherald.com/category/arts-culture/books/">books</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-11722"><a href="https://mbherald.com/category/arts-culture/music/">Music</a></li>
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-280"><a href="https://mbherald.com/category/arts-culture/film-theatre/">film/theatre</a></li>
	</ul>
</li>
	<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-273"><a href="https://mbherald.com/category/people/">People ></a>
	<ul class="sub-menu">
		<li class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-17255"><a href="https://mbherald.com/category/people/appointments/">Appointments</a></li>
	</ul>
</li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-963"><a href="https://mbherald.com/calendar/">Calendar</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-has-children menu-item-2596"><a href="https://mbherald.com/obituaries/">Obituaries</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37042"><a href="https://mbherald.com/obituary-submission/">Obituary submission</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37301"><a href="https://mbherald.com/subscribe/">Subscribe</a></li>
<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-37302"><a href="http://www.mennonitebrethren.ca/donate/">Donate</a></li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-10669"><a href="https://mbherald.com/about/">About</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26608"><a href="https://mbherald.com/about/website-privacy-policy/">Website Privacy Policy</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-26635"><a href="https://mbherald.com/about/website-terms-of-use/">Website terms of use</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-38858"><a href="https://mbherald.com/archives/">Archives</a></li>
</ul>
</li>
<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-275"><a href="https://mbherald.com/contact-us/">Contact Us</a>
<ul class="sub-menu">
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37017"><a href="https://mbherald.com/subscribe/">Subscribe</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-17256"><a href="https://mbherald.com/wp-content/uploads/2018/01/MBH-Family-Life-Announcements.2018.pdf">Family life announcements</a></li>
	<li class="menu-item menu-item-type-post_type menu-item-object-page menu-item-37041"><a href="https://mbherald.com/obituary-submission/">Obituary submission</a></li>
	<li class="menu-item menu-item-type-custom menu-item-object-custom menu-item-23779"><a href="https://mbherald.com/wp-content/uploads/2018/09/Media-Kit-web.pdf">Advertise</a></li>
</ul>
</li>
</ul>
				
				
				
				
				
			</div>
		</nav><!-- End Navigation -->
	</header>
<!-- end #header -->



			<div class="container penci-breadcrumb single-breadcrumb">
			<span><a class="crumb" href="https://mbherald.com/">Home</a></span><i class="fa fa-angle-right"></i>
			<span><a class="crumb" href="https://mbherald.com/category/arts-culture/">Arts &amp; Culture</a></span><i class="fa fa-angle-right"></i><span><a class="crumb" href="https://mbherald.com/category/arts-culture/art/">art</a></span><i class="fa fa-angle-right"></i>			<span>Are you exercising spiritual faith?</span>
		</div>
	
			<div class="container container-single container-single-fullwidth">
					

				


	<div class="header-standard header-classic single-header penci-title-bellow">
		
		<h1 class="post-title single-post-title">Are you exercising spiritual faith?</h1>

					<div class="post-box-meta-single">
													<span>November 19, 2018</span>
													<span>0 comment</span>
							</div>
			</div>

				</div>
	
	<div class="container container-single penci_sidebar right-sidebar penci-enable-lightbox">
		<div id="main" class="penci-main-sticky-sidebar">
			<div class="theiaStickySidebar">
														<article id="post-42273" class="post-42273 post type-post status-publish format-standard has-post-thumbnail hentry category-art category-arts-culture tag-arisnel-mesidor tag-discipleship tag-faith tag-global-church tag-lloyd-letkeman">

	
				
	
	<div class="post-entry blockquote-style-1">
		<div class="inner-post-entry">
			<h2>The Faith That Moves Mountains: How to Have It, How to Use It, and How to Protect It<br />
Arisnel Mesidor</h2>
<h5>Review by Lloyd M. Letkeman</h5>
<h3><span style="color: #0092cf;">What is the subject?</span></h3>
<div id="attachment_42276" style="width: 310px" class="wp-caption alignright"><img class="size-medium wp-image-42276" src="https://i2.wp.com/mbherald.com/wp-content/uploads/2018/11/Lloyd-Arisnel-313778.jpg?resize=300%2C225&#038;ssl=1" alt="Faith that moves mountains" width="300" height="225" srcset="https://i2.wp.com/mbherald.com/wp-content/uploads/2018/11/Lloyd-Arisnel-313778.jpg?resize=300%2C225&amp;ssl=1 300w, https://i2.wp.com/mbherald.com/wp-content/uploads/2018/11/Lloyd-Arisnel-313778.jpg?resize=768%2C576&amp;ssl=1 768w, https://i2.wp.com/mbherald.com/wp-content/uploads/2018/11/Lloyd-Arisnel-313778.jpg?resize=640%2C480&amp;ssl=1 640w, https://i2.wp.com/mbherald.com/wp-content/uploads/2018/11/Lloyd-Arisnel-313778.jpg?resize=1170%2C878&amp;ssl=1 1170w, https://i2.wp.com/mbherald.com/wp-content/uploads/2018/11/Lloyd-Arisnel-313778.jpg?resize=585%2C439&amp;ssl=1 585w" sizes="(max-width: 300px) 100vw, 300px" data-recalc-dims="1" /><p class="wp-caption-text">Reviewer Lloyd Letkeman and author Arisnel Mesidor at MCC’s social enterprise bookstore and cafe.</p></div>
<p><em>The Faith that Moves Mountains</em> is about activating and operationalizing our faith in God. Author Arisnel Mesidor’s intent is to help the reader understand faith and to wield it boldly according to Jesus’ teaching and modelling.</p>
<h3><span style="color: #0092cf;">Who is the author?</span></h3>
<p>Originally from Haiti, now rooted in Winnipeg, Arisnel Mesidor is a husband and father of two. He holds a MA in theology from Canadian Mennonite University and MB Seminary. From 2012 to 2017, he provided pastoral leadership to Église Communautaire de la Rivière Rouge, a Mennonite Brethren church in Winnipeg.  Presently, Arisnel is the coordinator of the migration and resettlement program at Mennonite Central Committee Manitoba.</p>
<h3><span style="color: #0092cf;">Why this book?</span></h3>
<p>I chose to read this book for two reasons.</p>
<p>First, I know Arisnel to be a man of integrity, humility, knowledge and wisdom. Therefore, I was confident that inspired nuggets of insight would be found within his book.</p>
<p>Second, as a white settler of European descent and as a teacher prone to skepticism, I wanted to read something that would challenge my perspective of praying by faith.</p>
<h3><span style="color: #0092cf;">Comment regarding the <a href="https://www.mennonitebrethren.ca/mb-beliefs/">MB Confession of Faith</a></span></h3>
<p>Arisnel reminds us that we often slip into having only natural faith, faith in what we can see, hear, or sense instead of boldly exercising spiritual faith.</p>
<p>Don’t assume this is a ‘name it &amp; claim it’ theological perspective; it is not.</p>
<p>I see Arisnel’s work firmly rooted in an Anabaptist theology: centred in Jesus, living out faith in community, and joining the Holy Spirit in the ministry of reconciliation.</p>
<p><em>The Faith That Moves Mountains</em> is an invitation to reclaim the Anabaptist faith of the Radical Reformation.</p>
<p>Every article in the Canadian Conference of MB Churches’ Statement of Faith begins with the words, “We believe” – a reminder of our faith in the unseen God and the empowerment of the Holy Spirit. This book echoes our statements of faith <em><strong>and</strong></em> urges us to boldly live them out.</p>
<h3><span style="color: #0092cf;">Key insights</span></h3>
<ul>
<li>Faith speaks to the mountains in our life and commands them to move.</li>
<li>Faith that moves mountains is spiritual (from the heart).</li>
<li>Faith is hindered by unforgiveness and doubt. Faith is activated in forgiveness and belief.</li>
</ul>
<h3><span style="color: #0092cf;">Downside</span></h3>
<p>A nagging question remained with me to the last page of the book, “What about unanswered prayer? Where is faith when the mountain does not move?” But I found the answer to my question… This is the topic of Arisnel’s next book!</p>
<h3><span style="color: #0092cf;">Why you should read it?</span></h3>
<p>First, this book will challenge your sensibilities and build your faith.</p>
<p>For me, it was an answer to my prayers to battle skepticism and embrace faith more boldly.</p>
<p>If you have mountains to overcome, read it. If your church is facing a mountain, consider this for your next home group book study.</p>
<p>Secondly, Arisnel is a third culture person, raised in Haiti with his post-secondary education in Canada and experience as an MB pastor and an MCC administrator. He has an oral story telling style of explanation for each insight or lesson.  Many paragraphs begin with an appeal to the reader, “Friend”, which invited me into his work with a posture of hospitality.</p>
<p>As friends and international family members of Anabaptist evangelicals around the globe, we must read each other’s work. <em>The Faith That Moves Mountains</em> provides a solidly scriptural perspective of exercising faith from a Haitian brother.</p>
<h3><span style="color: #0092cf;">Favourite quotes</span></h3>
<blockquote><p>“Many of the things we do as Christians, we do them not in order to become who we are in Christ but as a result of who we already are in Christ.”</p></blockquote>
<p>&nbsp;</p>
<blockquote><p>“Despite the circumstances around us and the thoughts in our mind, in our hearts we know that God has a plan to give us a future with hope. When the mountains seem irremovable in our physical eyes, in our hearts we believe that nothing is impossible for our God, and with our spiritual eyes, we can see them move already.</p></blockquote>
<p>&nbsp;</p>
<blockquote><p>“…not feeling good about something should not necessarily prevent us from moving forward if we know in our hearts that this is what God wants. Remember, feelings come from the flesh and the soul.”</p></blockquote>
<p><strong>[Lloyd Letkeman</strong> <em>is Central Canada mission mobilizer for MB Mission/Multiply. He and Carol live in Winnipeg, where they attend The Meeting Place.</em></p>
<div class="hatom-extra" style="display:none !important;visibility:hidden;"><span class="entry-title">Are you exercising spiritual faith?</span> was last modified: <span class="updated"> November 19th, 2018</span> by <span class="author vcard"><span class="fn">Reviewer</span></span></div><div class="sharedaddy sd-sharing-enabled"><div class="robots-nocontent sd-block sd-social sd-social-icon sd-sharing"><h3 class="sd-title">Share this:</h3><div class="sd-content"><ul><li class="share-facebook"><a rel="nofollow noopener noreferrer" data-shared="sharing-facebook-42273" class="share-facebook sd-button share-icon no-text" href="https://mbherald.com/faith-mountains/?share=facebook" target="_blank" title="Click to share on Facebook"><span></span><span class="sharing-screen-reader-text">Click to share on Facebook (Opens in new window)</span></a></li><li class="share-twitter"><a rel="nofollow noopener noreferrer" data-shared="sharing-twitter-42273" class="share-twitter sd-button share-icon no-text" href="https://mbherald.com/faith-mountains/?share=twitter" target="_blank" title="Click to share on Twitter"><span></span><span class="sharing-screen-reader-text">Click to share on Twitter (Opens in new window)</span></a></li><li class="share-google-plus-1"><a rel="nofollow noopener noreferrer" data-shared="sharing-google-42273" class="share-google-plus-1 sd-button share-icon no-text" href="https://mbherald.com/faith-mountains/?share=google-plus-1" target="_blank" title="Click to share on Google+"><span></span><span class="sharing-screen-reader-text">Click to share on Google+ (Opens in new window)</span></a></li><li class="share-linkedin"><a rel="nofollow noopener noreferrer" data-shared="sharing-linkedin-42273" class="share-linkedin sd-button share-icon no-text" href="https://mbherald.com/faith-mountains/?share=linkedin" target="_blank" title="Click to share on LinkedIn"><span></span><span class="sharing-screen-reader-text">Click to share on LinkedIn (Opens in new window)</span></a></li><li class="share-pocket"><a rel="nofollow noopener noreferrer" data-shared="" class="share-pocket sd-button share-icon no-text" href="https://mbherald.com/faith-mountains/?share=pocket" target="_blank" title="Click to share on Pocket"><span></span><span class="sharing-screen-reader-text">Click to share on Pocket (Opens in new window)</span></a></li><li class="share-print"><a rel="nofollow noopener noreferrer" data-shared="" class="share-print sd-button share-icon no-text" href="https://mbherald.com/faith-mountains/#print" target="_blank" title="Click to print"><span></span><span class="sharing-screen-reader-text">Click to print (Opens in new window)</span></a></li><li class="share-end"></li></ul></div></div></div>															<div class="post-tags">
						<a href="https://mbherald.com/tag/arisnel-mesidor/" rel="tag">Arisnel Mesidor</a><a href="https://mbherald.com/tag/discipleship/" rel="tag">discipleship</a><a href="https://mbherald.com/tag/faith/" rel="tag">faith</a><a href="https://mbherald.com/tag/global-church/" rel="tag">global church</a><a href="https://mbherald.com/tag/lloyd-letkeman/" rel="tag">Lloyd Letkeman</a>					</div>
									</div>
	</div>

	
			<div class="tags-share-box center-box">

							<span class="single-comment-o hide-comments-o"><i class="fa fa-comment-o"></i>0 comment</span>
			
					</div>
	
			<div class="post-author">
	<div class="author-img">
		<img alt='' src='https://secure.gravatar.com/avatar/a8678e3b38970293c3b66267c4c2cf82?s=100&#038;d=mm&#038;r=g' srcset='https://secure.gravatar.com/avatar/a8678e3b38970293c3b66267c4c2cf82?s=200&#038;d=mm&#038;r=g 2x' class='avatar avatar-100 photo' height='100' width='100' />	</div>
	<div class="author-content">
		<h5><a href="https://mbherald.com/author/reviewer/" title="Posts by Reviewer" rel="author">Reviewer</a></h5>
		<p></p>
															</div>
</div>	
	
					<div class="post-related">
		<div class="post-title-box"><h4 class="post-box-title">You may also like</h4></div>
		<div class="penci-owl-carousel penci-owl-carousel-slider penci-related-carousel" data-lazy="true" data-item="3" data-desktop="3" data-tablet="2" data-tabsmall="2" data-auto="false" data-speed="300" data-dots="true">
						<div class="item-related">
																		<a class="related-thumb penci-image-holder owl-lazy" data-src="https://i2.wp.com/mbherald.com/wp-content/uploads/2018/10/bk-ht-grow.jpg?resize=585%2C390&amp;ssl=1" href="https://mbherald.com/how-to-grow/" title="Hacks for spiritual growth">
																			</a>
										<h3><a href="https://mbherald.com/how-to-grow/">Hacks for spiritual growth</a></h3>
										<span class="date">October 22, 2018</span>
									</div>
						<div class="item-related">
										<h3><a href="https://mbherald.com/into-deep-waters/">Into deep waters</a></h3>
										<span class="date">October 10, 2018</span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder owl-lazy" data-src="https://i0.wp.com/mbherald.com/wp-content/uploads/2018/10/mbseminary-fall2018.jpg?resize=585%2C390&amp;ssl=1" href="https://mbherald.com/healthy-body-healthy-spirit/" title="Healthy body, healthy spirit">
																			</a>
										<h3><a href="https://mbherald.com/healthy-body-healthy-spirit/">Healthy body, healthy spirit</a></h3>
										<span class="date">October 1, 2018</span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder owl-lazy" data-src="https://i1.wp.com/mbherald.com/wp-content/uploads/2018/01/crosscurrents-mbherald-compressed.gif?resize=585%2C390&amp;ssl=1" href="https://mbherald.com/refugee-memoir/" title="From IDP to rooted: a refugee’s story">
																			</a>
										<h3><a href="https://mbherald.com/refugee-memoir/">From IDP to rooted: a refugee’s story</a></h3>
										<span class="date">September 17, 2018</span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder owl-lazy" data-src="https://i1.wp.com/mbherald.com/wp-content/uploads/2018/01/crosscurrents-mbherald-compressed.gif?resize=585%2C390&amp;ssl=1" href="https://mbherald.com/life-without-lack/" title="Abudant life in Christ">
																			</a>
										<h3><a href="https://mbherald.com/life-without-lack/">Abudant life in Christ</a></h3>
										<span class="date">August 6, 2018</span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder owl-lazy" data-src="https://i1.wp.com/mbherald.com/wp-content/uploads/2017/07/WWW-2.jpg?resize=585%2C390&amp;ssl=1" href="https://mbherald.com/article-10/" title="Article 10: Discipleship">
																			</a>
										<h3><a href="https://mbherald.com/article-10/">Article 10: Discipleship</a></h3>
										<span class="date">July 4, 2018</span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder owl-lazy" data-src="https://i1.wp.com/mbherald.com/wp-content/uploads/2018/01/news-2018.gif?resize=585%2C390&amp;ssl=1" href="https://mbherald.com/gameo-goes-global/" title="GAMEO goes global">
																			</a>
										<h3><a href="https://mbherald.com/gameo-goes-global/">GAMEO goes global</a></h3>
										<span class="date">June 6, 2018</span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder owl-lazy" data-src="https://i1.wp.com/mbherald.com/wp-content/uploads/2018/01/crosscurrents-mbherald-compressed.gif?resize=585%2C390&amp;ssl=1" href="https://mbherald.com/lifes-ultimate-questions/" title="Ask questions, enhance religious literacy">
																			</a>
										<h3><a href="https://mbherald.com/lifes-ultimate-questions/">Ask questions, enhance religious literacy</a></h3>
										<span class="date">April 16, 2018</span>
									</div>
						<div class="item-related">
																		<a class="related-thumb penci-image-holder owl-lazy" data-src="https://i0.wp.com/mbherald.com/wp-content/uploads/2018/01/Stories-from-Equip.jpg?resize=585%2C390&amp;ssl=1" href="https://mbherald.com/equip-hamster/" title="EQUIP: Kick the hamster off the wheel">
																			</a>
										<h3><a href="https://mbherald.com/equip-hamster/">EQUIP: Kick the hamster off the wheel</a></h3>
										<span class="date">January 26, 2018</span>
									</div>
						<div class="item-related">
										<h3><a href="https://mbherald.com/church-transforming-community/">Is your church a transforming community?</a></h3>
										<span class="date">October 31, 2017</span>
									</div>
		</div></div>	
			<div class="post-comments no-comment-yet" id="comments">
	<div id='comments_pagination'></div>	<div id="respond" class="comment-respond">
		<h3 id="reply-title" class="comment-reply-title"><span>Leave a Comment</span> <small><a rel="nofollow" id="cancel-comment-reply-link" href="/faith-mountains/#respond" style="display:none;">Cancel Reply</a></small></h3>			<form action="https://mbherald.com/wp-comments-post.php" method="post" id="commentform" class="comment-form">
				<p class="comment-form-comment"><textarea id="comment" name="comment" cols="45" rows="8" placeholder="Your Comment" aria-required="true"></textarea></p><p class="comment-form-author"><input id="author" name="author" type="text" value="" placeholder="Name*" size="30" aria-required='true' /></p>
<p class="comment-form-email"><input id="email" name="email" type="text" value="" placeholder="Email*" size="30" aria-required='true' /></p>
<p class="comment-form-url"><input id="url" name="url" type="text" value="" placeholder="Website" size="30" /></p>
<!-- MailChimp for WordPress v4.2.5 - https://mc4wp.com/ --><input type="hidden" name="_mc4wp_subscribe_wp-comment-form" value="0" /><p class="mc4wp-checkbox mc4wp-checkbox-wp-comment-form"><label><input type="checkbox" name="_mc4wp_subscribe_wp-comment-form" value="1"  /><span>Sign me up for the newsletter!</span></label></p><!-- / MailChimp for WordPress --><p class="form-submit"><input name="submit" type="submit" id="submit" class="submit" value="Submit" /> <input type='hidden' name='comment_post_ID' value='42273' id='comment_post_ID' />
<input type='hidden' name='comment_parent' id='comment_parent' value='0' />
</p>
<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf1N='c7a1dd38ce96d7e147146ee919e5e226';
hf1V='82c5949d11d277da900a8cce9bb972d3';
document.write("<input type='hidden' name='r3f5x9JS' value='"+r3f5x9JS+"' /><input type='hidden' name='"+hf1N+"' value='"+hf1V+"' />");
/* ]]> */
</script>
<noscript><input type="hidden" name="JS04X7" value="NS1" /></noscript>
<noscript><p><strong>Currently you have JavaScript disabled. In order to post comments, please make sure JavaScript and Cookies are enabled, and reload the page.</strong> <a href="http://enable-javascript.com/" rel="nofollow external" >Click here for instructions on how to enable JavaScript in your browser.</a></p></noscript>
			</form>
			</div><!-- #respond -->
	</div> <!-- end comments div -->
	
</article>							</div>
		</div>
					
<div id="sidebar" class="penci-sidebar-content style-4 pcalign-left penci-sticky-sidebar">
	<div class="theiaStickySidebar">
		<aside id="search-7" class="widget widget_search"><form role="search" method="get" id="searchform" action="https://mbherald.com/">
    <div>
		<input type="text" class="search-input" placeholder="Type and hit enter..." name="s" id="s" />
	 </div>
</form></aside><aside id="custom_html-2" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><div class="vc_row wpb_row vc_row-fluid"><div class="wpb_column vc_column_container vc_col-sm-12"><div class="vc_column-inner "><div class="wpb_wrapper"><div class="vc_btn3-container  wpb_animate_when_almost_visible wpb_right-to-left right-to-left vc_btn3-left" >
	<a onmouseleave="this.style.borderColor='#0093d0'; this.style.backgroundColor='transparent'; this.style.color='#0093d0'" onmouseenter="this.style.borderColor='#0093d0'; this.style.backgroundColor='#0093d0'; this.style.color='#ffffff';" style="border-color:#0093d0; color:#0093d0;" class="vc_general vc_btn3 vc_btn3-size-lg vc_btn3-shape-rounded vc_btn3-style-outline-custom vc_btn3-block vc_btn3-icon-left" href="http://mbherald.com/subscribe/" title="" target="_blank"><i class="vc_btn3-icon fa fa-sign-in"></i> SUBSCRIBE</a></div>
<div class="vc_btn3-container vc_btn3-left" >
	<a class="vc_general vc_btn3 vc_btn3-size-lg vc_btn3-shape-square vc_btn3-style-flat vc_btn3-block vc_btn3-icon-left vc_btn3-color-white" href="https://mbherald.com/spring-2018/" title="" target="_blank"><i class="vc_btn3-icon fa fa-newspaper-o"></i> Latest Issue</a></div>
<div class="vc_btn3-container vc_btn3-left" >
	<a class="vc_general vc_btn3 vc_btn3-size-lg vc_btn3-shape-square vc_btn3-style-flat vc_btn3-block vc_btn3-icon-left vc_btn3-color-white" href="http://jobs.mbherald.com" title="" target="_blank"><i class="vc_btn3-icon fa fa-briefcase"></i> jobs.mbherald.ca</a></div>
<div class="vc_btn3-container vc_btn3-left" >
	<a class="vc_general vc_btn3 vc_btn3-size-lg vc_btn3-shape-square vc_btn3-style-flat vc_btn3-block vc_btn3-icon-left vc_btn3-color-white" href="http://mbherald.com/multiply-podcast/" title="" target="_blank"><i class="vc_btn3-icon fa fa-microphone"></i> Multiply Podcast</a></div>
<div class="vc_btn3-container vc_btn3-left" >
	<a class="vc_general vc_btn3 vc_btn3-size-lg vc_btn3-shape-square vc_btn3-style-flat vc_btn3-block vc_btn3-icon-left vc_btn3-color-white" href="https://issuu.com/mbherald" title="" target="_blank"><i class="vc_btn3-icon entypo-icon entypo-icon-book-open"></i> Read on ISSUU</a></div>
<div class="vc_btn3-container vc_btn3-left" >
	<a class="vc_general vc_btn3 vc_btn3-size-lg vc_btn3-shape-square vc_btn3-style-flat vc_btn3-block vc_btn3-icon-left vc_btn3-color-white" href="http://www.mennonitebrethren.ca/donate/" title="" target="_blank"><i class="vc_btn3-icon fa fa-gift"></i> Donate</a></div>
</div></div></div></div></div></aside><aside id="custom_html-5" class="widget_text widget widget_custom_html"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">[social</span></h4><div class="textwidget custom-html-widget"><a class="twitter-timeline" data-height="700" href="https://twitter.com/MB_Herald?ref_src=twsrc%5Etfw">Tweets by MB_Herald</a> <script async src="https://platform.twitter.com/widgets.js" charset="utf-8"></script></div></aside><aside id="penci_facebook_widget-2" class="widget penci_facebook_widget">			<div class="fb-page" data-href="https://www.facebook.com/MBHerald/" data-small-header="false" data-adapt-container-width="true" data-hide-cover="false" data-show-facepile="true" data-show-posts="false"><div class="fb-xfbml-parse-ignore"><blockquote cite="https://www.facebook.com/MBHerald/"><a href="https://www.facebook.com/MBHerald/">Facebook</a></blockquote></div></div>
		</aside><aside id="rev-slider-widget-5" class="widget widget_revslider">
<div id="rev_slider_8_1_wrapper" class="rev_slider_wrapper fullwidthbanner-container" data-source="gallery" style="margin:0px auto;background:transparent;padding:0px;margin-top:0px;margin-bottom:0px;">
<!-- START REVOLUTION SLIDER 5.4.5.1 auto mode -->
	<div id="rev_slider_8_1" class="rev_slider fullwidthabanner" style="display:none;" data-version="5.4.5.1">
<ul>	<!-- SLIDE  -->
	<li data-index="rs-8" data-transition="fade" data-slotamount="default" data-hideafterloop="0" data-hideslideonmobile="off"  data-easein="default" data-easeout="default" data-masterspeed="300"  data-link="http://therussianmennonitestory.com/"  data-target="_blank"  data-thumb="https://i1.wp.com/mbherald.com/wp-content/uploads/2018/11/MB-Herald-750x750-online.jpg?fit=2000%2C2000&ssl=1"  data-rotate="0"  data-saveperformance="off"  data-title="Slide" data-param1="" data-param2="" data-param3="" data-param4="" data-param5="" data-param6="" data-param7="" data-param8="" data-param9="" data-param10="" data-description="">
		<!-- MAIN IMAGE -->
		<img src="https://i1.wp.com/mbherald.com/wp-content/uploads/2018/11/MB-Herald-750x750-online.jpg?fit=2000%2C2000&ssl=1"  alt="" title="MB Herald-750&#215;750-online"  width="2000" height="2000" data-bgposition="center center" data-bgfit="cover" data-bgrepeat="no-repeat" class="rev-slidebg" data-no-retina>
		<!-- LAYERS -->
	</li>
	<!-- SLIDE  -->
	<li data-index="rs-14" data-transition="fade" data-slotamount="default" data-hideafterloop="0" data-hideslideonmobile="off"  data-easein="default" data-easeout="default" data-masterspeed="300"  data-link="https://www.gmmitv.com/en"  data-target="_blank"  data-thumb="https://i1.wp.com/mbherald.com/wp-content/uploads/2018/09/gathering-ad-2.jpg?fit=1463%2C1430&ssl=1"  data-rotate="0"  data-saveperformance="off"  data-title="Slide" data-param1="" data-param2="" data-param3="" data-param4="" data-param5="" data-param6="" data-param7="" data-param8="" data-param9="" data-param10="" data-description="">
		<!-- MAIN IMAGE -->
		<img src="https://i1.wp.com/mbherald.com/wp-content/uploads/2018/09/gathering-ad-2.jpg?fit=1463%2C1430&ssl=1"  alt="" title="gathering-ad-2"  width="1463" height="1430" data-bgposition="center center" data-bgfit="cover" data-bgrepeat="no-repeat" class="rev-slidebg" data-no-retina>
		<!-- LAYERS -->
	</li>
	<!-- SLIDE  -->
	<li data-index="rs-9" data-transition="fade" data-slotamount="default" data-hideafterloop="0" data-hideslideonmobile="off"  data-easein="default" data-easeout="default" data-masterspeed="300"  data-link="http://www.mennonitebrethren.ca/service/events/"  data-target="_blank"  data-thumb="https://i1.wp.com/mbherald.com/wp-content/uploads/2018/09/equip2019savethedate.jpg?fit=2000%2C2000&ssl=1"  data-rotate="0"  data-saveperformance="off"  data-title="Slide" data-param1="" data-param2="" data-param3="" data-param4="" data-param5="" data-param6="" data-param7="" data-param8="" data-param9="" data-param10="" data-description="">
		<!-- MAIN IMAGE -->
		<img src="https://i1.wp.com/mbherald.com/wp-content/uploads/2018/09/equip2019savethedate.jpg?fit=2000%2C2000&ssl=1"  alt="" title="equip2019savethedate"  width="2000" height="2000" data-bgposition="center center" data-bgfit="cover" data-bgrepeat="no-repeat" class="rev-slidebg" data-no-retina>
		<!-- LAYERS -->
	</li>
</ul>
<script>var htmlDiv = document.getElementById("rs-plugin-settings-inline-css"); var htmlDivCss="";
						if(htmlDiv) {
							htmlDiv.innerHTML = htmlDiv.innerHTML + htmlDivCss;
						}else{
							var htmlDiv = document.createElement("div");
							htmlDiv.innerHTML = "<style>" + htmlDivCss + "</style>";
							document.getElementsByTagName("head")[0].appendChild(htmlDiv.childNodes[0]);
						}
					</script>
<div class="tp-bannertimer tp-bottom" style="visibility: hidden !important;"></div>	</div>
<script>var htmlDiv = document.getElementById("rs-plugin-settings-inline-css"); var htmlDivCss="";
				if(htmlDiv) {
					htmlDiv.innerHTML = htmlDiv.innerHTML + htmlDivCss;
				}else{
					var htmlDiv = document.createElement("div");
					htmlDiv.innerHTML = "<style>" + htmlDivCss + "</style>";
					document.getElementsByTagName("head")[0].appendChild(htmlDiv.childNodes[0]);
				}
			</script>
		<script type="text/javascript">
setREVStartSize({c: jQuery('#rev_slider_8_1'), gridwidth: [750], gridheight: [750], sliderLayout: 'auto'});
			
var revapi8,
	tpj=jQuery;
			
tpj(document).ready(function() {
	if(tpj("#rev_slider_8_1").revolution == undefined){
		revslider_showDoubleJqueryError("#rev_slider_8_1");
	}else{
		revapi8 = tpj("#rev_slider_8_1").show().revolution({
			sliderType:"standard",
			jsFileLocation:"//mbherald.com/wp-content/plugins/revslider/public/assets/js/",
			sliderLayout:"auto",
			dottedOverlay:"none",
			delay:9000,
			navigation: {
				keyboardNavigation:"off",
				keyboard_direction: "horizontal",
				mouseScrollNavigation:"off",
 							mouseScrollReverse:"default",
				onHoverStop:"off",
				arrows: {
					style:"uranus",
					enable:true,
					hide_onmobile:false,
					hide_onleave:true,
					hide_delay:200,
					hide_delay_mobile:1200,
					tmp:'',
					left: {
						h_align:"left",
						v_align:"center",
						h_offset:20,
						v_offset:0
					},
					right: {
						h_align:"right",
						v_align:"center",
						h_offset:20,
						v_offset:0
					}
				}
			},
			visibilityLevels:[1240,1024,778,480],
			gridwidth:750,
			gridheight:750,
			lazyType:"none",
			shadow:0,
			spinner:"spinner0",
			stopLoop:"off",
			stopAfterLoops:-1,
			stopAtSlide:-1,
			shuffle:"off",
			autoHeight:"off",
			disableProgressBar:"on",
			hideThumbsOnMobile:"off",
			hideSliderAtLimit:0,
			hideCaptionAtLimit:0,
			hideAllCaptionAtLilmit:0,
			debugMode:false,
			fallbacks: {
				simplifyAll:"off",
				nextSlideOnWindowFocus:"off",
				disableFocusListener:false,
			}
		});
	}
	
});	/*ready*/
</script>
		<script>
					var htmlDivCss = unescape("%23rev_slider_8_1%20.uranus.tparrows%20%7B%0A%20%20width%3A50px%3B%0A%20%20height%3A50px%3B%0A%20%20background%3Argba%28255%2C255%2C255%2C0%29%3B%0A%20%7D%0A%20%23rev_slider_8_1%20.uranus.tparrows%3Abefore%20%7B%0A%20width%3A50px%3B%0A%20height%3A50px%3B%0A%20line-height%3A50px%3B%0A%20font-size%3A40px%3B%0A%20transition%3Aall%200.3s%3B%0A-webkit-transition%3Aall%200.3s%3B%0A%20%7D%0A%20%0A%20%20%23rev_slider_8_1%20.uranus.tparrows%3Ahover%3Abefore%20%7B%0A%20%20%20%20opacity%3A0.75%3B%0A%20%20%7D%0A");
					var htmlDiv = document.getElementById('rs-plugin-settings-inline-css');
					if(htmlDiv) {
						htmlDiv.innerHTML = htmlDiv.innerHTML + htmlDivCss;
					}
					else{
						var htmlDiv = document.createElement('div');
						htmlDiv.innerHTML = '<style>' + htmlDivCss + '</style>';
						document.getElementsByTagName('head')[0].appendChild(htmlDiv.childNodes[0]);
					}
				  </script>
				</div><!-- END REVOLUTION SLIDER --></aside><aside id="recent-comments-4" class="widget widget_recent_comments"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">[recent comments</span></h4><ul id="recentcomments"><li class="recentcomments"><span class="comment-author-link">Tim Durksen</span> on <a href="https://mbherald.com/a-good-meal/#comment-49082">A good meal</a></li><li class="recentcomments"><span class="comment-author-link">Jacqueline Block</span> on <a href="https://mbherald.com/more-than-8000-postcards-delivered-on-world-food-day/#comment-49080">More than 8,000 postcards delivered on World Food Day</a></li><li class="recentcomments"><span class="comment-author-link"><a href='http://jordanduerrstein.wordpress.com' rel='external nofollow' class='url'>Jordan Duerrstein</a></span> on <a href="https://mbherald.com/national-ministry-team-sept-18/#comment-49078">Inspire, equip, encourage the church</a></li><li class="recentcomments"><span class="comment-author-link">Dan Johnson</span> on <a href="https://mbherald.com/article-14/#comment-41887">Article 14</a></li><li class="recentcomments"><span class="comment-author-link">Rick Block</span> on <a href="https://mbherald.com/into-deep-waters/#comment-35856">Into deep waters</a></li></ul></aside><aside id="archives-5" class="widget widget_archive"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">[archives</span></h4>		<label class="screen-reader-text" for="archives-dropdown-5">[archives</label>
		<select id="archives-dropdown-5" name="archive-dropdown" onchange='document.location.href=this.options[this.selectedIndex].value;'>
			
			<option value="">Select Month</option>
				<option value='https://mbherald.com/2018/11/'> November 2018 </option>
	<option value='https://mbherald.com/2018/10/'> October 2018 </option>
	<option value='https://mbherald.com/2018/09/'> September 2018 </option>
	<option value='https://mbherald.com/2018/08/'> August 2018 </option>
	<option value='https://mbherald.com/2018/07/'> July 2018 </option>
	<option value='https://mbherald.com/2018/06/'> June 2018 </option>
	<option value='https://mbherald.com/2018/05/'> May 2018 </option>
	<option value='https://mbherald.com/2018/04/'> April 2018 </option>
	<option value='https://mbherald.com/2018/03/'> March 2018 </option>
	<option value='https://mbherald.com/2018/02/'> February 2018 </option>
	<option value='https://mbherald.com/2018/01/'> January 2018 </option>
	<option value='https://mbherald.com/2017/12/'> December 2017 </option>
	<option value='https://mbherald.com/2017/11/'> November 2017 </option>
	<option value='https://mbherald.com/2017/10/'> October 2017 </option>
	<option value='https://mbherald.com/2017/09/'> September 2017 </option>
	<option value='https://mbherald.com/2017/08/'> August 2017 </option>
	<option value='https://mbherald.com/2017/07/'> July 2017 </option>
	<option value='https://mbherald.com/2017/06/'> June 2017 </option>
	<option value='https://mbherald.com/2017/05/'> May 2017 </option>
	<option value='https://mbherald.com/2017/04/'> April 2017 </option>
	<option value='https://mbherald.com/2017/03/'> March 2017 </option>
	<option value='https://mbherald.com/2017/02/'> February 2017 </option>
	<option value='https://mbherald.com/2017/01/'> January 2017 </option>
	<option value='https://mbherald.com/2016/12/'> December 2016 </option>
	<option value='https://mbherald.com/2016/11/'> November 2016 </option>
	<option value='https://mbherald.com/2016/10/'> October 2016 </option>
	<option value='https://mbherald.com/2016/09/'> September 2016 </option>
	<option value='https://mbherald.com/2016/08/'> August 2016 </option>
	<option value='https://mbherald.com/2016/07/'> July 2016 </option>
	<option value='https://mbherald.com/2016/06/'> June 2016 </option>
	<option value='https://mbherald.com/2016/05/'> May 2016 </option>
	<option value='https://mbherald.com/2016/04/'> April 2016 </option>
	<option value='https://mbherald.com/2016/03/'> March 2016 </option>
	<option value='https://mbherald.com/2016/02/'> February 2016 </option>
	<option value='https://mbherald.com/2016/01/'> January 2016 </option>
	<option value='https://mbherald.com/2015/12/'> December 2015 </option>
	<option value='https://mbherald.com/2015/11/'> November 2015 </option>
	<option value='https://mbherald.com/2015/10/'> October 2015 </option>
	<option value='https://mbherald.com/2015/09/'> September 2015 </option>
	<option value='https://mbherald.com/2015/08/'> August 2015 </option>
	<option value='https://mbherald.com/2015/07/'> July 2015 </option>
	<option value='https://mbherald.com/2015/06/'> June 2015 </option>
	<option value='https://mbherald.com/2015/05/'> May 2015 </option>
	<option value='https://mbherald.com/2015/04/'> April 2015 </option>
	<option value='https://mbherald.com/2015/03/'> March 2015 </option>
	<option value='https://mbherald.com/2015/02/'> February 2015 </option>
	<option value='https://mbherald.com/2015/01/'> January 2015 </option>
	<option value='https://mbherald.com/2014/12/'> December 2014 </option>
	<option value='https://mbherald.com/2014/11/'> November 2014 </option>
	<option value='https://mbherald.com/2014/10/'> October 2014 </option>
	<option value='https://mbherald.com/2014/09/'> September 2014 </option>
	<option value='https://mbherald.com/2014/08/'> August 2014 </option>
	<option value='https://mbherald.com/2014/07/'> July 2014 </option>
	<option value='https://mbherald.com/2014/06/'> June 2014 </option>
	<option value='https://mbherald.com/2014/05/'> May 2014 </option>
	<option value='https://mbherald.com/2014/04/'> April 2014 </option>
	<option value='https://mbherald.com/2014/03/'> March 2014 </option>
	<option value='https://mbherald.com/2014/02/'> February 2014 </option>
	<option value='https://mbherald.com/2014/01/'> January 2014 </option>
	<option value='https://mbherald.com/2013/12/'> December 2013 </option>
	<option value='https://mbherald.com/2013/11/'> November 2013 </option>
	<option value='https://mbherald.com/2013/10/'> October 2013 </option>
	<option value='https://mbherald.com/2013/09/'> September 2013 </option>
	<option value='https://mbherald.com/2013/08/'> August 2013 </option>
	<option value='https://mbherald.com/2013/07/'> July 2013 </option>
	<option value='https://mbherald.com/2013/06/'> June 2013 </option>
	<option value='https://mbherald.com/2013/05/'> May 2013 </option>
	<option value='https://mbherald.com/2013/04/'> April 2013 </option>
	<option value='https://mbherald.com/2013/03/'> March 2013 </option>
	<option value='https://mbherald.com/2013/02/'> February 2013 </option>
	<option value='https://mbherald.com/2013/01/'> January 2013 </option>
	<option value='https://mbherald.com/2012/12/'> December 2012 </option>
	<option value='https://mbherald.com/2012/11/'> November 2012 </option>
	<option value='https://mbherald.com/2012/10/'> October 2012 </option>
	<option value='https://mbherald.com/2012/09/'> September 2012 </option>
	<option value='https://mbherald.com/2012/08/'> August 2012 </option>
	<option value='https://mbherald.com/2012/07/'> July 2012 </option>
	<option value='https://mbherald.com/2012/06/'> June 2012 </option>
	<option value='https://mbherald.com/2012/05/'> May 2012 </option>
	<option value='https://mbherald.com/2012/04/'> April 2012 </option>
	<option value='https://mbherald.com/2012/03/'> March 2012 </option>
	<option value='https://mbherald.com/2012/02/'> February 2012 </option>
	<option value='https://mbherald.com/2012/01/'> January 2012 </option>
	<option value='https://mbherald.com/2011/12/'> December 2011 </option>
	<option value='https://mbherald.com/2011/11/'> November 2011 </option>
	<option value='https://mbherald.com/2011/10/'> October 2011 </option>
	<option value='https://mbherald.com/2011/09/'> September 2011 </option>
	<option value='https://mbherald.com/2011/08/'> August 2011 </option>
	<option value='https://mbherald.com/2011/07/'> July 2011 </option>
	<option value='https://mbherald.com/2011/06/'> June 2011 </option>
	<option value='https://mbherald.com/2011/05/'> May 2011 </option>
	<option value='https://mbherald.com/2011/04/'> April 2011 </option>
	<option value='https://mbherald.com/2011/03/'> March 2011 </option>
	<option value='https://mbherald.com/2011/02/'> February 2011 </option>
	<option value='https://mbherald.com/2011/01/'> January 2011 </option>
	<option value='https://mbherald.com/2010/12/'> December 2010 </option>
	<option value='https://mbherald.com/2010/11/'> November 2010 </option>
	<option value='https://mbherald.com/2010/10/'> October 2010 </option>
	<option value='https://mbherald.com/2010/09/'> September 2010 </option>
	<option value='https://mbherald.com/2010/08/'> August 2010 </option>
	<option value='https://mbherald.com/2010/07/'> July 2010 </option>
	<option value='https://mbherald.com/2010/06/'> June 2010 </option>
	<option value='https://mbherald.com/2010/05/'> May 2010 </option>
	<option value='https://mbherald.com/2010/04/'> April 2010 </option>
	<option value='https://mbherald.com/2010/03/'> March 2010 </option>
	<option value='https://mbherald.com/2010/02/'> February 2010 </option>
	<option value='https://mbherald.com/2010/01/'> January 2010 </option>
	<option value='https://mbherald.com/2009/12/'> December 2009 </option>
	<option value='https://mbherald.com/2009/11/'> November 2009 </option>
	<option value='https://mbherald.com/2009/10/'> October 2009 </option>
	<option value='https://mbherald.com/2009/09/'> September 2009 </option>
	<option value='https://mbherald.com/2009/08/'> August 2009 </option>
	<option value='https://mbherald.com/2009/07/'> July 2009 </option>
	<option value='https://mbherald.com/2009/06/'> June 2009 </option>
	<option value='https://mbherald.com/2009/05/'> May 2009 </option>
	<option value='https://mbherald.com/2009/04/'> April 2009 </option>
	<option value='https://mbherald.com/2009/03/'> March 2009 </option>
	<option value='https://mbherald.com/2009/02/'> February 2009 </option>
	<option value='https://mbherald.com/2009/01/'> January 2009 </option>
	<option value='https://mbherald.com/2008/12/'> December 2008 </option>
	<option value='https://mbherald.com/2008/11/'> November 2008 </option>
	<option value='https://mbherald.com/2008/10/'> October 2008 </option>
	<option value='https://mbherald.com/2008/09/'> September 2008 </option>
	<option value='https://mbherald.com/2008/08/'> August 2008 </option>
	<option value='https://mbherald.com/2008/07/'> July 2008 </option>
	<option value='https://mbherald.com/2008/06/'> June 2008 </option>
	<option value='https://mbherald.com/2008/05/'> May 2008 </option>
	<option value='https://mbherald.com/2008/04/'> April 2008 </option>
	<option value='https://mbherald.com/2008/03/'> March 2008 </option>
	<option value='https://mbherald.com/2008/02/'> February 2008 </option>
	<option value='https://mbherald.com/2008/01/'> January 2008 </option>
	<option value='https://mbherald.com/2007/12/'> December 2007 </option>
	<option value='https://mbherald.com/2007/11/'> November 2007 </option>
	<option value='https://mbherald.com/2007/09/'> September 2007 </option>
	<option value='https://mbherald.com/2007/06/'> June 2007 </option>
	<option value='https://mbherald.com/2007/04/'> April 2007 </option>
	<option value='https://mbherald.com/2007/03/'> March 2007 </option>
	<option value='https://mbherald.com/2006/12/'> December 2006 </option>
	<option value='https://mbherald.com/2006/11/'> November 2006 </option>
	<option value='https://mbherald.com/2006/09/'> September 2006 </option>
	<option value='https://mbherald.com/2006/03/'> March 2006 </option>
	<option value='https://mbherald.com/2006/02/'> February 2006 </option>
	<option value='https://mbherald.com/2006/01/'> January 2006 </option>
	<option value='https://mbherald.com/2005/11/'> November 2005 </option>
	<option value='https://mbherald.com/2005/09/'> September 2005 </option>
	<option value='https://mbherald.com/2005/07/'> July 2005 </option>
	<option value='https://mbherald.com/2005/06/'> June 2005 </option>
	<option value='https://mbherald.com/2005/05/'> May 2005 </option>
	<option value='https://mbherald.com/2005/04/'> April 2005 </option>
	<option value='https://mbherald.com/2005/01/'> January 2005 </option>
	<option value='https://mbherald.com/2004/11/'> November 2004 </option>
	<option value='https://mbherald.com/2004/07/'> July 2004 </option>
	<option value='https://mbherald.com/2004/04/'> April 2004 </option>
	<option value='https://mbherald.com/2004/03/'> March 2004 </option>
	<option value='https://mbherald.com/2004/02/'> February 2004 </option>
	<option value='https://mbherald.com/2004/01/'> January 2004 </option>
	<option value='https://mbherald.com/2003/12/'> December 2003 </option>
	<option value='https://mbherald.com/2003/10/'> October 2003 </option>
	<option value='https://mbherald.com/2003/05/'> May 2003 </option>
	<option value='https://mbherald.com/2002/03/'> March 2002 </option>
	<option value='https://mbherald.com/2002/01/'> January 2002 </option>
	<option value='https://mbherald.com/2001/12/'> December 2001 </option>
	<option value='https://mbherald.com/2001/11/'> November 2001 </option>
	<option value='https://mbherald.com/2001/10/'> October 2001 </option>
	<option value='https://mbherald.com/2001/08/'> August 2001 </option>
	<option value='https://mbherald.com/2001/03/'> March 2001 </option>
	<option value='https://mbherald.com/2000/12/'> December 2000 </option>
	<option value='https://mbherald.com/2000/09/'> September 2000 </option>
	<option value='https://mbherald.com/2000/07/'> July 2000 </option>
	<option value='https://mbherald.com/2000/03/'> March 2000 </option>
	<option value='https://mbherald.com/2000/02/'> February 2000 </option>
	<option value='https://mbherald.com/2000/01/'> January 2000 </option>
	<option value='https://mbherald.com/1999/10/'> October 1999 </option>
	<option value='https://mbherald.com/1998/11/'> November 1998 </option>
	<option value='https://mbherald.com/1997/12/'> December 1997 </option>
	<option value='https://mbherald.com/1997/08/'> August 1997 </option>
	<option value='https://mbherald.com/1996/09/'> September 1996 </option>
	<option value='https://mbherald.com/1995/12/'> December 1995 </option>
	<option value='https://mbherald.com/1994/11/'> November 1994 </option>
	<option value='https://mbherald.com/1994/05/'> May 1994 </option>
	<option value='https://mbherald.com/1992/04/'> April 1992 </option>
	<option value='https://mbherald.com/1990/04/'> April 1990 </option>
	<option value='https://mbherald.com/1988/05/'> May 1988 </option>
	<option value='https://mbherald.com/1983/03/'> March 1983 </option>
	<option value='https://mbherald.com/1981/12/'> December 1981 </option>
	<option value='https://mbherald.com/1981/11/'> November 1981 </option>
	<option value='https://mbherald.com/1981/02/'> February 1981 </option>
	<option value='https://mbherald.com/1978/04/'> April 1978 </option>
	<option value='https://mbherald.com/1972/05/'> May 1972 </option>

		</select>
		</aside><aside id="categories-2" class="widget widget_categories"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">[categories</span></h4><form action="https://mbherald.com" method="get"><label class="screen-reader-text" for="cat">[categories</label><select  name='cat' id='cat' class='postform' >
	<option value='-1'>Select Category</option>
	<option class="level-0" value="412">Anniversaries</option>
	<option class="level-0" value="411">Appointments</option>
	<option class="level-0" value="20">art</option>
	<option class="level-0" value="13">Arts &amp; Culture</option>
	<option class="level-0" value="35">Bible study</option>
	<option class="level-0" value="17">books</option>
	<option class="level-0" value="6">Columns</option>
	<option class="level-0" value="8">Crosscurrents</option>
	<option class="level-0" value="37">feature articles</option>
	<option class="level-0" value="5">Features</option>
	<option class="level-0" value="19">film/theatre</option>
	<option class="level-0" value="25">From CCMBC executive</option>
	<option class="level-0" value="26">From the community</option>
	<option class="level-0" value="24">From the editor</option>
	<option class="level-0" value="31">Homepage</option>
	<option class="level-0" value="36">inspirational</option>
	<option class="level-0" value="126">Letters to the editor</option>
	<option class="level-0" value="14">Life &amp; Faith</option>
	<option class="level-0" value="21">MB Herald</option>
	<option class="level-0" value="252">music</option>
	<option class="level-0" value="1">News</option>
	<option class="level-0" value="12">People</option>
	<option class="level-0" value="7">People and Events</option>
	<option class="level-0" value="4443">podcast</option>
	<option class="level-0" value="15">Views</option>
</select>
</form>
<script type='text/javascript'>
/* <![CDATA[ */
(function() {
	var dropdown = document.getElementById( "cat" );
	function onCatChange() {
		if ( dropdown.options[ dropdown.selectedIndex ].value > 0 ) {
			dropdown.parentNode.submit();
		}
	}
	dropdown.onchange = onCatChange;
})();
/* ]]> */
</script>

</aside><aside id="blog_subscription-5" class="widget jetpack_subscription_widget"><h4 class="widget-title penci-border-arrow"><span class="inner-arrow">[subscribe to blog via email</span></h4>
			<form action="#" method="post" accept-charset="utf-8" id="subscribe-blog-blog_subscription-5">
				<div id="subscribe-text"><p>Receive notifications of new posts by email.</p>
</div>					<p id="subscribe-email">
						<label id="jetpack-subscribe-label" for="subscribe-field-blog_subscription-5">
							Email Address						</label>
						<input type="email" name="email" required="required" class="required" value="" id="subscribe-field-blog_subscription-5" placeholder="Email Address" />
					</p>

					<p id="subscribe-submit">
						<input type="hidden" name="action" value="subscribe" />
						<input type="hidden" name="source" value="https://mbherald.com/faith-mountains/" />
						<input type="hidden" name="sub-type" value="widget" />
						<input type="hidden" name="redirect_fragment" value="blog_subscription-5" />
												<input type="submit" value="Subscribe" name="jetpack_subscriptions_widget" />
					</p>
							</form>

			<script>
			/*
			Custom functionality for safari and IE
			 */
			(function( d ) {
				// In case the placeholder functionality is available we remove labels
				if ( ( 'placeholder' in d.createElement( 'input' ) ) ) {
					var label = d.querySelector( 'label[for=subscribe-field-blog_subscription-5]' );
						label.style.clip 	 = 'rect(1px, 1px, 1px, 1px)';
						label.style.position = 'absolute';
						label.style.height   = '1px';
						label.style.width    = '1px';
						label.style.overflow = 'hidden';
				}

				// Make sure the email value is filled in before allowing submit
				var form = d.getElementById('subscribe-blog-blog_subscription-5'),
					input = d.getElementById('subscribe-field-blog_subscription-5'),
					handler = function( event ) {
						if ( '' === input.value ) {
							input.focus();

							if ( event.preventDefault ){
								event.preventDefault();
							}

							return false;
						}
					};

				if ( window.addEventListener ) {
					form.addEventListener( 'submit', handler, false );
				} else {
					form.attachEvent( 'onsubmit', handler );
				}
			})( document );
			</script>
				
</aside>	</div>
</div>		
<!-- END CONTAINER -->
</div>
<div class="clear-footer"></div>


		<div id="widget-area">
			<div class="container">
									<div class="footer-widget-wrapper footer-widget-style-1">
						<aside id="rev-slider-widget-4" class="widget widget_revslider">
<div id="rev_slider_7_2_wrapper" class="rev_slider_wrapper fullwidthbanner-container" data-source="gallery" style="margin:0px auto;background:transparent;padding:0px;margin-top:0px;margin-bottom:0px;">
<!-- START REVOLUTION SLIDER 5.4.5.1 auto mode -->
	<div id="rev_slider_7_2" class="rev_slider fullwidthabanner" style="display:none;" data-version="5.4.5.1">
<ul>	<!-- SLIDE  -->
	<li data-index="rs-7" data-transition="fade" data-slotamount="default" data-hideafterloop="0" data-hideslideonmobile="off"  data-easein="default" data-easeout="default" data-masterspeed="300"  data-link="http://mbherald.com/subscribe/"   data-rotate="0"  data-saveperformance="off"  data-title="Slide" data-param1="" data-param2="" data-param3="" data-param4="" data-param5="" data-param6="" data-param7="" data-param8="" data-param9="" data-param10="" data-description="">
		<!-- MAIN IMAGE -->
		<img src="https://i0.wp.com/mbherald.com/wp-content/uploads/2018/01/subscribe.png?fit=2000%2C250&ssl=1"  alt="" title="subscribe"  width="2000" height="250" data-bgposition="center center" data-bgfit="cover" data-bgrepeat="no-repeat" class="rev-slidebg" data-no-retina>
		<!-- LAYERS -->
	</li>
</ul>
<div class="tp-bannertimer" style="height: 2px; background: rgba(255,255,255,1);"></div>	</div>
<script>var htmlDiv = document.getElementById("rs-plugin-settings-inline-css"); var htmlDivCss="";
				if(htmlDiv) {
					htmlDiv.innerHTML = htmlDiv.innerHTML + htmlDivCss;
				}else{
					var htmlDiv = document.createElement("div");
					htmlDiv.innerHTML = "<style>" + htmlDivCss + "</style>";
					document.getElementsByTagName("head")[0].appendChild(htmlDiv.childNodes[0]);
				}
			</script>
		<script type="text/javascript">
setREVStartSize({c: jQuery('#rev_slider_7_2'), gridwidth: [2000], gridheight: [250], sliderLayout: 'auto'});
			
var revapi7,
	tpj=jQuery;
			
tpj(document).ready(function() {
	if(tpj("#rev_slider_7_2").revolution == undefined){
		revslider_showDoubleJqueryError("#rev_slider_7_2");
	}else{
		revapi7 = tpj("#rev_slider_7_2").show().revolution({
			sliderType:"standard",
			jsFileLocation:"//mbherald.com/wp-content/plugins/revslider/public/assets/js/",
			sliderLayout:"auto",
			dottedOverlay:"none",
			delay:9000,
			navigation: {
				onHoverStop:"off",
			},
			visibilityLevels:[1240,1024,778,480],
			gridwidth:2000,
			gridheight:250,
			lazyType:"none",
			shadow:0,
			spinner:"spinner0",
			stopLoop:"off",
			stopAfterLoops:-1,
			stopAtSlide:-1,
			shuffle:"on",
			autoHeight:"off",
			hideThumbsOnMobile:"off",
			hideSliderAtLimit:0,
			hideCaptionAtLimit:0,
			hideAllCaptionAtLilmit:0,
			debugMode:false,
			fallbacks: {
				simplifyAll:"off",
				nextSlideOnWindowFocus:"off",
				disableFocusListener:false,
			}
		});
	}
	
});	/*ready*/
</script>
		</div><!-- END REVOLUTION SLIDER --></aside>					</div>
					<div class="footer-widget-wrapper footer-widget-style-1">
											</div>
					<div class="footer-widget-wrapper footer-widget-style-1 last">
											</div>
							</div>
		</div>



<footer id="footer-section" class="penci-footer-social-media penci-lazy">
	<div class="container">
									<div class="footer-socials-section">
					<ul class="footer-socials">
													<li><a href="https://www.facebook.com/MBHerald/" target="_blank"><i class="fa fa-facebook"></i><span>Facebook</span></a></li>
																			<li><a href="https://twitter.com/MB_Herald" target="_blank"><i class="fa fa-twitter"></i><span>Twitter</span></a></li>
																																																																																																																																									</ul>
				</div>
										<div class="footer-logo-copyright footer-not-logo">
				
				
									<div id="footer-copyright">
						<p><a href="http://www.mennonitebrethren.ca"> <img src="https://mbherald.com/wp-content/uploads/2018/01/Horizontal-Logo-Rev.png" width="350px">
</a>
<br>
© Mennonite Brethren Herald, 2018</p>
					</div>
													<div class="go-to-top-parent"><a href="#" class="go-to-top"><span><i class="fa fa-angle-up"></i><br>Back To Top</span></a></div>
							</div>
							<div class="penci-go-to-top-floating"><i class="fa fa-angle-up"></i></div>
			</div>
</footer>

</div><!-- End .wrapper-boxed -->

<div id="fb-root"></div>


<script type='text/javascript'>
/* <![CDATA[ */
r3f5x9JS=escape(document['referrer']);
hf4N='c7a1dd38ce96d7e147146ee919e5e226';
hf4V='82c5949d11d277da900a8cce9bb972d3';
cm4S="form[action='https://mbherald.com/wp-comments-post.php']";
jQuery(document).ready(function($){var e="#commentform, .comment-respond form, .comment-form, "+cm4S+", #lostpasswordform, #registerform, #loginform, #login_form, #wpss_contact_form, .gform_wrapper form";$(e).submit(function(){$("<input>").attr("type","hidden").attr("name","r3f5x9JS").attr("value",r3f5x9JS).appendTo(e);return true;});var h="form[method='post']";$(h).submit(function(){$("<input>").attr("type","hidden").attr("name",hf4N).attr("value",hf4V).appendTo(h);return true;});});
/* ]]> */
</script> 
		<script>
		( function ( body ) {
			'use strict';
			body.className = body.className.replace( /\btribe-no-js\b/, 'tribe-js' );
		} )( document.body );
		</script>
		<script> /* <![CDATA[ */var tribe_l10n_datatables = {"aria":{"sort_ascending":": activate to sort column ascending","sort_descending":": activate to sort column descending"},"length_menu":"Show _MENU_ entries","empty_table":"No data available in table","info":"Showing _START_ to _END_ of _TOTAL_ entries","info_empty":"Showing 0 to 0 of 0 entries","info_filtered":"(filtered from _MAX_ total entries)","zero_records":"No matching records found","search":"Search:","all_selected_text":"All items on this page were selected. ","select_all_link":"Select all pages","clear_selection":"Clear Selection.","pagination":{"all":"All","next":"Next","previous":"Previous"},"select":{"rows":{"0":"","_":": Selected %d rows","1":": Selected 1 row"}},"datepicker":{"dayNames":["Sunday","Monday","Tuesday","Wednesday","Thursday","Friday","Saturday"],"dayNamesShort":["Sun","Mon","Tue","Wed","Thu","Fri","Sat"],"dayNamesMin":["S","M","T","W","T","F","S"],"monthNames":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesShort":["January","February","March","April","May","June","July","August","September","October","November","December"],"monthNamesMin":["Jan","Feb","Mar","Apr","May","Jun","Jul","Aug","Sep","Oct","Nov","Dec"],"nextText":"Next","prevText":"Prev","currentText":"Today","closeText":"Done","today":"Today","clear":"Clear"}};var tribe_system_info = {"sysinfo_optin_nonce":"c939d61518","clipboard_btn_text":"Copy to clipboard","clipboard_copied_text":"System info copied","clipboard_fail_text":"Press \"Cmd + C\" to copy"};/* ]]> */ </script>
	<script type="text/javascript">
		window.WPCOM_sharing_counts = {"https:\/\/mbherald.com\/faith-mountains\/":42273};
	</script>
							<script type="text/javascript">
				function revslider_showDoubleJqueryError(sliderID) {
					var errorMessage = "Revolution Slider Error: You have some jquery.js library include that comes after the revolution files js include.";
					errorMessage += "<br> This includes make eliminates the revolution slider libraries, and make it not work.";
					errorMessage += "<br><br> To fix it you can:<br>&nbsp;&nbsp;&nbsp; 1. In the Slider Settings -> Troubleshooting set option:  <strong><b>Put JS Includes To Body</b></strong> option to true.";
					errorMessage += "<br>&nbsp;&nbsp;&nbsp; 2. Find the double jquery.js include and remove it.";
					errorMessage = "<span style='font-size:16px;color:#BC0C06;'>" + errorMessage + "</span>";
						jQuery(sliderID).show().html(errorMessage);
				}
			</script>
			<link rel='stylesheet' id='js_composer_front-css'  href='https://mbherald.com/wp-content/plugins/js_composer/assets/css/js_composer.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='animate-css-css'  href='https://mbherald.com/wp-content/plugins/js_composer/assets/lib/bower/animate-css/animate.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='font-awesome-css'  href='https://mbherald.com/wp-content/plugins/js_composer/assets/lib/bower/font-awesome/css/font-awesome.min.css?ver=5.2.1' type='text/css' media='all' />
<link rel='stylesheet' id='vc_entypo-css'  href='https://mbherald.com/wp-content/plugins/js_composer/assets/css/lib/vc-entypo/vc_entypo.min.css?ver=5.2.1' type='text/css' media='all' />
<script type='text/javascript' src='https://mbherald.com/wp-content/plugins/jetpack/_inc/build/photon/photon.min.js?ver=20130122'></script>
<script type='text/javascript' src='https://s0.wp.com/wp-content/js/devicepx-jetpack.js?ver=201847'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/themes/soledad/js/libs-script.min.js?ver=4.0.2'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/themes/soledad/js/retina.min.js?ver=1.0'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/themes/soledad/js/smoothscroll.js?ver=1.0'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/themes/soledad/js/main.js?ver=4.0.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var ajax_var = {"url":"https:\/\/mbherald.com\/wp-admin\/admin-ajax.php","nonce":"f7d3178078"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mbherald.com/wp-content/themes/soledad/js/post-like.js?ver=4.0.2'></script>
<script type='text/javascript' src='https://mbherald.com/wp-includes/js/comment-reply.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/plugins/jetpack/_inc/build/likes/queuehandler.min.js?ver=6.7'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/plugins/wp-spamshield/js/jscripts-ftr2-min.js'></script>
<script type='text/javascript' src='https://mbherald.com/wp-includes/js/wp-embed.min.js?ver=4.9.8'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/plugins/js_composer/assets/js/dist/js_composer_front.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/plugins/js_composer/assets/lib/waypoints/waypoints.min.js?ver=5.2.1'></script>
<script type='text/javascript' src='https://mbherald.com/wp-content/themes/soledad/js/facebook.js?ver=4.0.2'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var sharing_js_options = {"lang":"en","counts":"1","is_stats_active":"1"};
/* ]]> */
</script>
<script type='text/javascript' src='https://mbherald.com/wp-content/plugins/jetpack/_inc/build/sharedaddy/sharing.min.js?ver=6.7'></script>
<script type='text/javascript'>
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-facebook', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomfacebook', 'menubar=1,resizable=1,width=600,height=400' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-twitter', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomtwitter', 'menubar=1,resizable=1,width=600,height=350' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-google-plus-1', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomgoogle-plus-1', 'menubar=1,resizable=1,width=480,height=550' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-linkedin', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcomlinkedin', 'menubar=1,resizable=1,width=580,height=450' );
				return false;
			});
var windowOpen;
			jQuery( document.body ).on( 'click', 'a.share-pocket', function() {
				// If there's another sharing window open, close it.
				if ( 'undefined' !== typeof windowOpen ) {
					windowOpen.close();
				}
				windowOpen = window.open( jQuery( this ).attr( 'href' ), 'wpcompocket', 'menubar=1,resizable=1,width=450,height=450' );
				return false;
			});
</script>
<script type='text/javascript' src='https://stats.wp.com/e-201847.js' async='async' defer='defer'></script>
<script type='text/javascript'>
	_stq = window._stq || [];
	_stq.push([ 'view', {v:'ext',j:'1:6.7',blog:'40563152',post:'42273',tz:'-6',srv:'mbherald.com'} ]);
	_stq.push([ 'clickTrackerInit', '40563152', '42273' ]);
</script>


</body>
</html>
<!--
Performance optimized by W3 Total Cache. Learn more: https://www.w3-edge.com/products/


Served from: mbherald.com @ 2018-11-19 08:59:55 by W3 Total Cache
-->